Blender 3D: Noob to Pro/Şipşak render

Vikikitap, özgür kütüphane
Gezinti kısmına atla Arama kısmına atla
İlk hızlı ve çirkin 3B çıktınız buna benzer bir şey olacaktır.

Eğer daha önceki rehberi bitirmediyseniz, (Hızlı modelleme rehberi), şimdi bitirin. O rehberdeki aynı dosyayı açık tutun çünkü onu burada kullanacağız.

Bir render kameranın bakış açısından çevrenin sahneye olan etkisini hesaba katarak, ayarlarınızı temel alarak gerçekçi bir resim oluşturmaktır. Bu render çok çabuk bitecektir, ancak sizin 3B sahnelerinizde karmaşıklaştıkça, render çok uzun süre alabilir.

Varolan sahneyi render etmek[değiştir]

Şimdi ilk modelinizi oluşturdunuz, kuşkusuz render etmeyi isteyeceksiniz. Render hızlı ve basittir. Nesne kipinde (object mode) olduğunuzdan emin olun (eğer değilseniz TAB'a basın), fare okunu 3B görünüm penceresinin içine sokun ve F12'ye basın! Macintosh OS X 10.4 ve Gnome'da ise ALT-F12 kullanarak sırası ile kontrol paneli ve Gnome arama diyaloğundan kaçınmış olursunuz.

Eğer 1'den fazla işlemciniz varsa renderlarınız hızlandırmanın bir yolu var. Dolayısıyla birden fazla işlemci çekirdeğiniz varsa, okumaya devam edin. Eğer yoksa bu paragrafı atlayın. F10'a basarak render ayarları sekmesine gidin ve sol alt köşede, threads düğmesi var. İşlemcinizdeki uygun çekirdek sayısına ayarlamak için numarayı ayarlayın. (Çift çekirdekte iki thread olabilir. Her bir çekirdeğe bir değer atanır) Şimdi, tekrar renderlayın ve daha hızlı sonuç alacaksınız. Çok çekirdek her zaman için işlerinizi daha hızlı yapmanızı sağlayacaktır bu nedenle çok çekirdek almanızı tavsiye ediyoruz.

Menu Render Current Frame.jpg

Menüden de kullanabilirsiniz: Render > Render Current Frame. Sonra, herhangi bir zamanda renderı kesmek için ESC basın. (Eğer kazara render penceresini ana pencerenin arkasına koyduysanız, geri getirmenizin birkaç yolu var: Pencere görev çubuğunu kullanabilirsiniz veya pencere ve çoğu operatör sistemleri altında, ALT+TAB (CMD-~(tilde) on Mac) kullanabilirsiniz.)

F12 tuşu sıklıkla render almakta kullanılmaktadır ve render almak için en kestirme yoldur.

Not: Eğer küp veya herhangi bir nesne tamamıyla siyahsa, sahnede bir ışık kaynağı bulunmamaktadır. Blender'ın bazı versiyonlarında varsayılan olarak ışık kaynağı oluşturulmamaktadır ve ihtiyacına göre eklemelisin. Bir lamba eklemek için, nesne mode (object mode) TAB tuşu ile girilir ve spacebar'a basılır. Mouse ucu 3D Viewport üzerinde olmalı. Spacebar'a basınca karşınıza çıkan menüden Add > Lamp seçmelisiniz. Farklı tipteki lambalardan seçebilirsiniz. Küpün içine olmamak kaydıyla ışığı uygun bir konuma yerleştirin. Bu taşıma işlemini yapamazsanız önce taşıyacağınız nesneye sağ tıklayın RMB ve G tuşuna basın.

F12 - Aktif kameradan render başlatır.

Renderı kaydetmek[değiştir]

Bazen renderınızı kaydetmek isteyeceksinizdir. 3D Viewport'un üstünde File > Save Rendered Image… veya F3 basın. Klasör listesiyle bir menü gözükecektir. Üsteki yazı satırı klasörü ve alttaki yazı satırı ise image'ın ismi ve tipi ("myfirstrendering.jpg" gibi) belirtilmektedir. Not Blender'ın ilk versiyonlarında (Blender 2.41 öncesi) JPG formatı ekli olarak görünmeyecektir.

JPEG resimleri PNG resimleri ile karşılaştırıldığında kenar çizgileri kusurlar içermektedir. Render -> Render Settings veya F10 tuşuna basarak formatı değiştirebilirsiniz. Format paneli altında Jpeg'ten PNG'ye tipi değitirin ve F3 tuşuna basıp renderınızı tekrar kaydedin.

F3 - Save Image diyaloğunu açmaktadır.


Önceki ders -- Sonraki ders