Blender 3D: Noob to Pro/Basit bir karakter modellemek

Vikikitap, özgür kütüphane
Gezinti kısmına atla Arama kısmına atla

Herşey

Şimdi, basit bir karakter yapacağız, extrusion ve polygon seçimi hakkında bilgi edineceksiniz. Extrusion en çok ve geniş çapta kullanılan modelleme araçlarından biridir.

Yeni Proje Oluşturmak[değiştir]

Basit karakteriniz buna benzeyecek.

Blender'ı başlatın, sahne default(varsayılan) olarak başlayacaktır.(Açıklamalar için tıklayın). Default başladığında küb olacaktır.

Hatırlatma:

  • Kübü RMB yani sağ tıklayarak seçilir (Mac kullanıcıları CMD+LMB kombinasyonu ile yapabilir).
  • Sahneye farklı açılardan bakmak için MMB orta tuş(top) basıp sürükleyerek bakabilirsiniz (Mac kullanıcılarıALT+LMB ile yapar).
  • NUM7 bastığınızda üstten görünüşü gösterir.
  • Edit Mode ve Object mode arasında seçim yapmak için TAB tuşu kullanılır; aşağıdaki resimde gösterilmektedir. TAB tuşunu kullanmadan da değişiklikleri yapabilirsiniz:
    Mode button/indicator

Yöntemleri Seçmek[değiştir]

Blender3D Simple Person First Selection.png

Bu kısımda küpün üsteki dört noktayı seçmek için 6 metod önerilecektir. Sağda gösterilen resimde görüntü döndürülerek istenilen noktalar seçildi.

Bu buton nesnenin arkasının görünmesini kapatmaktadır

Öncelikle başlarken, nesnemizin nokta ve kenar gibi seçimleri rahat bir şekilde yapabilmek için Düzenleme kipinde nesnenin arka tarafta kalan kenar ve noktaların gözükmesini engellemek gerekmektedir. (Yandaki resimde küp şeklinde buton.) Bu sınırlı görünen bir seçim işlemi sağlar. (Blender 2.46'da Occlude background geometry olarak isimlendirilmektedir.) Düzenleme kipindeyken bu tuşa basın. Wireframe Mode da bulunmayabilir : eğer bulamadıysanız Z tuşuna basın. 3D View penceresinin altında, sağ tarafa doğru, Render butonundan önce görünecektir.

'Not:' In Blender 2.42 for Mac OS X running on a MacBook, there is a display problem with the box and circle selections: the selection box and circle do not appear on screen (this is valid for both the Intel and the PowerPC versions).

Varsayılan ayar Object Mode modudur. Küp seçilmiş olmalıdır; Object Mode modudan Edit Mode moduna geçilmelidir. (Listeden seçin.)

1. Kutu Seçimi[değiştir]

Bu araç bir kare çizmektedir böylelikle üsteki dört noktayı kare çizerek seçilir.

  1. A-Tuşu ile seçili olan her şeyi seçimden çıkartın;
  2. B-Tuşuna basıp aktif hale getirin.

Şimdi,LMB sol mouse tuşuna basılı tutup mouse'u hareket ettirin, seçim kenarları gözükecektir. Mouse butonunu bırakırken,noktalar içeride kalacak şekilde olmalıdır böylelikle seçilecektir. Üsteki dört noktayı seçin. Eğer hata yaptıysanız, A-Tuşuna basıp seçimi iptal edip noktaları seçmeye tekrar başlayabilirsiniz. Bir sonraki metodu denemeden önce şüphesiz bütün noktaların seçimi iptal edilmiş olmalıdır. (Noktaların seçimi iptal edilince pembe olurlar, sarı değil)

BKEY - Kutu-seçim aracı aktif hale getirir.

2. Çember Seçimi[değiştir]

  1. A-Tuşuna basarak seçili bütün noktaların seçimini iptal edin;
  2. B-Tuşuna iki kez basıp Çember kenarlı seçim aracını aktif hale getirin.(V.2.69'da C-Tuşu)

Mouse kürsörü etrafında bir çember gözükecektir. SCROLL (mouse tekeri) ile çemberin boyutunu ayarlayabilirsiniz veya alternatif olarak NUM+/NUM- veya PgUp/PgDn tuşlarını kullanabilirsiniz.

  • LMB (mouse sol tuşu) ile sürükle bırak ile noktaların herbirini seçin veya birkaç kez tıklayarak seçin.
  • MMB (veya ALT+LMB) ile noktaları tıklayarak veya sürükleyerek noktaları seçimden çıkarabilirsiniz.


Not: Eğer ALT + LMB mevcut çalıştığınız pencereyi hareket ettirir, o sebepler CTRL+ALT+LMB veya MMB kullanarak noktaları seçimden çıkarabilirsiniz (Dikkat!!! sçim aracı aktif halde iken).

Çember Kenarlı Seçim aracı RMB, ESC veya SPACE basana kadar aktif halde olur.


B-Tuşu+B-Tuşu - Dairesel seçim. Eğer B-Tuşuna ikinci kez basıldıktan sonra sınırlı seçim yapabilirsiniz. NUM+ ve NUM- veya MW(mouse orta tuş) dairenin boyutunu ayarlar. RMB veya ESC ile dairesel seçimden çıkabilirsiniz.

3. Lasso(Kement) Seçimi[değiştir]

Blender 3D sahip olduğu lasso seçim aracı çoğu grafiksel programlardakine benzer.

  1. A-Tuşuna basarak bütün noktaları seçimden çıkarın;
  2. CTRL+LMB basılı tutun ve noktaların etrafında çember çizerek istediğiniz gibi seçin. LMB (sol mouse tuşu) serbest bırakın.

Aynı şekilde lasso ile seçimi iptal etmek için, CTRL+SHIFT+LMB kullanılır.

4. Tek Tek Seçmek[değiştir]

Dört noktayı tek tekte seçebilirsiniz

  1. A-Tuşu ile bütün noktaları seçimden çıkarın;
  2. RMB (Mac mouse'u tek butonunda CMD+LMB) ile tek noktayı seçin;
  3. SHIFT basılı iken RMB basarak noktaları tek tek seçin. Seçtiğiniz noktaların üzerine aynı şekilde tıklarsanız seçimden çıkarmış olursunuz.

5. Kenar Seçimi[değiştir]

Selection Modes

Vertex seçim metoduna ek olarak, diğer opsiyonlarda mevcuttur. Viewport başlığının sağında seçim modlarını görebilirsin. Edge select mode yani kenar seçim modunu seçin (iki paralel çizgi) ve küpün bir kenarını RMB ile seçin -- Eğer bütün kenarları seçili gözüküyorsa A tuşuna basıp seçimden çıkarın. A aynı zamanda hepsini seçmeye yarar -- (CMD+LMB tek buton Mac mouse). Sonra SHIFT+RMB ile seçtiğiniz kenarın karşısındaki kenarı seçin. Vertex select modea geri dönün (dört nokta). Her bir kenarın iki noktadan oluşması ve sizin karşılıklı iki kenarı seçerek Vertex select modea geri dönmeniz halinde dört noktayı seçili olarak göreceksiniz (buna "selection transformation - seçim dönüşümü" denilmektedir). Ayrıca bir sonraki yüzey seçim moduna geçmeniz halinde yine dört nokta seçili olduğunda otomatikman yüzeyi seçmiş olacaksınız.

6. Yüzey Seçimi[değiştir]

Seçme Modu

Vertex seçim metoduna ek olarak, diğer opsiyonlar da mevcuttur. Viewport başlığının sağında seçim modlarını görebilirsin. Face select mode yani yüzey seçim modunu seçin (içinde nokta olan üçgen) ve küpün yüzeyini RMB ile seçin ('CMD+LMB tek buton Mac mouse). Vertex select modea geri tıklayın (dört nokta). Bir yüzeyi seçmeniz aynı zamanda onu oluşturan dört noktayı seçmeniz anlamına geliyor. Bu yüzden bir yüzey (polygon demek aynı zamanda başka 3d programı kullananlar bilir) seçmeniz halinde nokta seçimine geri döndüğünüz anda yüzeyi oluşturan dört noktayı seçilmiş olarak göreceksiniz. (bu "selection transformation - seçim dönüşümü" olarak isimlendirilmektedir.

Alternatif olarak, 3D viewport'ta mouse ucu ile, CTRL+TAB tuşuna basabilir ve açılır menüden Vertices (noktalar) veya Faces (yüzeyler) seçebilirsiniz.

A-Tuşuna basarak seçilmiş yüzeyi seçimden çıkarabilirsiniz.

Extrusion'u Öğrenmek[değiştir]

Orthographic view

Aşağıdaki resimler orthographic görüntüdedir. Blender versiyonuna göre değişmektedir, Ön ayarlı görüntü perspective veya orthographic görüntüden biridir. Eğer orthographic'ye değiştirmeye ihtiyacınız varsa, NUM5 basın (veya VIEW menüsünden seçin, resimde görüldüğü gibi). İki boyutlu görüntüden yani orthographic görüntüyü düzeltmek için NUM1 tuşuna basın yandan görünüşlerde tek bir yön gözükmeyip çevresinden bazı kenarlar görüyosanız. perspective görüntü modundadır.

Bölgesel extrusion[değiştir]

Dört köşe seçip E-Tuşuna basın.(2 resim üste görünen şekli bakarak seçebilirsiniz) Çıkan menüden Region (bölge) seçin ve mouse hareket ettirin: Oluşacak dört yeni nokta daha önce seçmiş olduğunuz noktalar etrafında istediğiniz şekli vermenizi sağlayacak noktaları çıkartmış oldunuz böylelikle modelleme için gerekli nokta ve yüzey arttırımı ile ilgili bilgi sahbi oldunuz. İstediğniz kadar çekiştirmeden sonra bırakmak için LMB, SPACE, veya ENTER kullanabilirsiniz. Menüdeki herbir seçeneği deneyerek tecrübe edinin modellemede farklı durumlar için gerekli olabilir sonuçta çözüm üretmek bildiklerinizle olmaktadır

Notlar:

  • Eğer popup menü çıkmaz ise, büyük ihtimalle yüzey veya kenar seçim modundasınızdır. Nokta moduna geri dönerek menüyü çıkartabilirsiniz.
  • Eğer popup menüde Only Edges ve Only Vertices seçenekerli gözüküyorsa, bir yüzey oluşturan dört noktayı seçmediğiniz anlamına geliyordur. (Ayrıca bazı noktalarda iki kat nokta olabilir: Edit Mode durumunda iki bütün noktaları seçin --aynı köşede bulunan üst üste noktalar-- ve W-Tuşu basın Specials menü çıkacaktır. Menüden Remove Doubles seçin; Mesh Tools altında Rem Doubles dan da bu işlemi yaparak üst üste bulunan fazla noktaları silebilirsiniz).
  • Blender sürümlerine bağlı olarak işlemlerin yeri ve seçenekleri değişebilir. Bildiğiniz yoldan olmadığı takdirde sürüm bilgilerine inceleyin.

EKEY - Extrude seçimi

Basit bir bacak ile başlamak[değiştir]

Blender3D Simple Person Step1.png

Editleme işlemleirnden geri almak için U-Tuşu veya CTRL+Z-tuşu (CMD+Z-tuşu Mac) basın. Blender'ı yeniden başlatıp küp seçili iken Edit moduna geçin üsteki dört nokta seçili değil ise seçin.

Şimdi E-Tuşuna basın. Region seçin. Extrude noktalarını taşıyın, CTRL tuşuna basılı tutarak hareket ettirin. Böylelikle CTRL basarak sadece belli mesafeye kadar taşıma işleminin sınırlandırıldığını görüceksiniz. Bu işleme snapping denilmektedir. snap noktaları önceden belirlenmiş pozisyonlara atlatır. Snap yani belirlenmiş pozisyonlar hakkında daha sonra anlatıcağız, fakat şimdilik, noktaları doğru pozisyonlarda ayarlar böylelik görüntü iki küpün üst üste binmiş haline benziyecektir.

Beş kutu üst üste duruyomuş gibi yaptığınız extrude olayını tekrar edin. Ve bu, my friend, is a very simple leg! ----Adamın arkadaşı :)) ----

Ve şimdi, the pelvis - kalça kemiği[değiştir]

Blender3D Simple Person Step2.png

A-tuşu'na basıp seçili noktalardan seçimi kaldırın. Üstteki küpün sağ yüzeyinde dört noktayı seçin. Daha iyi görmek için görüntüyü döndürmek isteyebilirsiniz, bu sebeple MMB ile (unutmadıysanız mouse'un orta butonu ya da topu) görüntüyü döndürebilirsiniz. Alternatif olarak, kutu seçim aracı ile görünen noktaların arksındaki noktalarıda seçebilirsiniz (B-Tuşu). İki kez extrude uygulayın.

Diğer gövdenin parçlarını çizmek[değiştir]

Aynı hüneri bitirene kadar tekrarlayın ve basit gövdemizin kalanları yapılıp bitecektir.

Tek tıklama ile bir yüzeyin dört noktasını Face select mode anahtarı ile seçmek isteyebilirsiniz. Bu yol extrusion araçları extrude işleminde region otomatiktir, böylelikle yüzey extrude yaparken her seferinde Region seçmeniz gerekmeyecektir.

Bu noktada modeliniz görüntünüzde (ekranda)

Bu noktada modeliniz görüntünüzde (ekranda) sığacak kadar çok büyük görülebilir. Görüntüyü ayarlamak için:

  • CTRL tuşuna basılı tutun ve NUM4, NUM8, NUM6, NUM2 tuşlarına basın,
  • veya SHIFT basılı tutun ve MMB ile sürükleyin.

şimdi, drum kontrol: Z-Tuşuna basıp solid mode açın ve gövdeyi inceleyin. Eğer bazı yüzeyler kayıpsa, kolaylıkla düzeltilir. Dört nokta bir yüzey oluşturmaktadır, dört nokta seçin ve F-tuşuna basın (veya choose the Mesh → Make Edge/Face menu from the viewport header). Fazla noktaları kaldırmak için W-Tuşu basın ve menüden Remove Doubles seçin. Fazla noktaları kaldırmak için üst üste binen noktaların hepsini seçmeyi unutmayın.

Baş Eklemek[değiştir]

You have to be in Edit Mode now.

Önemlit not: başı eklerken Edit Mode (resimdeki gibi) durumunda olmalısınız. Eğer değilseniz, baş ve gövde aynı nesnenin parçaları olmuyacaktır ve gövdedeki değişiklikler gövdeye etkimiyecektir, bir sonraki bölümde gereklidir.

Select a point just above the top of the neck using the LMB: the red and white circle is the cursor. To adjust the cursor's position, switch between the top, front and side views (using the NUM7, NUM1, and NUM3 key respectively). You can also use the snap tool: press SHIFT+S to bring up the snap menu and select Cursor → Grid.

Once you're happy with the position, press the SPACE key to bring up the popup menu. Select Add → Icosphere. In some Blender versions you may have to choose the subdivision number. Just click OK. You should now have a small sphere at the top of the body. To make it more proportional to the body, resize it with the scale tool:

  • select Mesh → Transform → Scale from the viewport menu,
  • while holding LMB, draw a triangle on the screen,
  • or just press the SKEY.

If you deselect the head and then decide that you want to move it or resize it again, select one vertex of the head, then click Select → Linked Vertices (or use CTRL+L). All the head's vertices will then be selected again, and none of the body's. Then press GKEY to grab and move the head, or SKEY to resize it. Hold down CTRL as you move it around if you would like it to snap to the grid.

Don't forget that you are in 3D; use the MMB to move your point of view around to make sure that the head really sticks in the neck.

Note: to make your character more realistic, add Blender's monkey head instead of the icosphere. The path is: SPACE → Add → Monkey (don't forget to do it in Edit Mode).

Another note:


Here is the person with a monkey head, its just as easy as the Icosphere. You place the cursor at the right spot (In the middle of the top box) and then you create a monkey. SPACE → Add → Monkey. Then you scale it. I scaled it with 2. But I found it a little bit far to the back so I placed it forward with 0,6.

There you go, a monkey person.


Özet: Tuşlar & Komutlar[değiştir]

Bu sayfada tuşların ve komutların kullanımı vardır:

Tuş Biçim Tanım
RMB veya CMD+LMB (Tek butonlu mouse Mac Kullanıcılar için) Nesne Bir nesne seçme
NUM1 Önden görünüşe gider
TAB Edit Mode ve Object Mode arasında geçiş
B-Tuşu sonra LMB ve basıp sürükleme Kutu seçimi
A-Tuşu Hepsini seçme veya seçimi iptal etme arasında geçiş
B-Tuşu B-Tuşu (iki kez basmak) sonra LMB ve sürüklemek Çember seçim
CTRL+LMB and drag Lasso(kement) seçimi
RMB sonra SHIFT+RMB Tek tek seçmek
(Nokta/kenar/yüzey seçmek için üzerlerini tıklamak) Seçim modunu değiştirmek
CMD+TAB (Windows/UNIX'de CTRL+TAB) Seçim modunu değiştirmek
seçili noktalar sonra E-Tuşu Extrude
CTRL extrude yapılırken Yapışkanlığı aktifler
MMB veya ALT+LMB 3D görüntüyü döndürür
Z-Tuşu Wireframe/solid görüntü arasında değişim
F-Tuşu Seçili noktalardan Kenar/Yüzey yapar
NUM3 Yandan görünüm
SHIFT+S-Tuşu İmleci veya seçili nesneyi istenilen konuma getirmek için kullanılır. -- Not: ingilizce anlatımım farklı fakat kullanım amacı konumlandırmayı kolaylaştırmak deneyerek tecrübe edinin --
G-Tuşu Geçerli seçimi tutup taşımayı sağlar
Z-Tuşu (veya X-Tuşu veya Y-Tuşu) taşıma (grab-kapış) modu (GKEY) Taşımak istediğini bir nesneyi düzlemsel olarak Z (veya X veya Y) ekseninde taşımak için kullanılır. Önce G-Tuşu sonra X-Tuşu, Y-Tuşu veya Z-Tuşuna basın ve hareket ettirin.
S-Tuşu Seçili nesnenizi ölçeklendirme yani boyutlarını değiştirmek için kullanılır
SPACE Nesne, kamera, ışık, çizgi ve düzenleme araçları gibi birçok araca ulaşmak için menü çıkartır
W-Tuşu Nesne editlerken ve normal olarak sahnede tıklanması durumunda farklı menüler ve araçlar çıkmaktadır. Araçlarını örnekleri çalışarak öğrenebilirsiniz.


Herşey