Blender 3D: Noob to Pro/Başlama ipuçları

Vikikitap, özgür kütüphane
Gezinti kısmına atla Arama kısmına atla

These are some basic tips that are often asked for in one form or another. Sometimes it is in reference to something completely different, but the basic methodology will work.

Kutu ile başlamak[değiştir]

Ön tanımlı küp

Genelde rehberler Blender'ı açınca karşınıza çıkan ön tanımlı küp ile başlar. Burada sahneyi uygulamadan çıkmadan sıfırdan başlatmak için iki yol vardır:

  • Ctrl-X ( Ctrl tuşuna basarken, X tuşuna basın);
  • veya menüden File -> New (Dosya -> Yeni).

Sonra, fare imleci altında izin isteyen OK? kutucuğunu göreceksiniz. Bunu Erase All seçeneğini seçerek (ya da dismiss ite getirip iptal ederek) onaylayarak şu anki sahneyi silebilirsiniz.

3B görüntü penceresinde bir küp kare gibi görünür. (Eğer fare orta tuşu ile görünüşü çevirirseniz, onun geçekten küp olduğunu görürsünüz.) Bu ön tanımlı seçilmiştir.

Not: Ön tanımlı sahneyi değiştirebilirsiniz. (Ctrl-X 'e basarak kişiselleştirilmiş olana dönebilirsiniz.) Sadece sahneyi düzenleyin ve ihtiyaçlarınıza göre diyalogları ayarlayın, sonra File > Save Default Settingse (Dosya > Ön Tanımlı Ayarlar tıklayın.) Bu aslında çok kullanışlıdır. Fabrika ayarlarına geri dönmek için, bu ayarların tutulduğu ev dizinindeki .B.blend dosyasını silin. Sürüm 2.44'den itibaren, File (Dosya) menüsündeki yeni Load Factory Settings (Fabrika Ayarlarını yükle) seçeneği bulunmaktadır.

Subdivision (Alt bölüm) yüzeyleri[değiştir]

Alt bölüm yüzeyleri, ya da alt yüzleme (subsurfing), 3B modellemede sık rastlanılan bir tekniktir. O matematik işlemleri kullanarak kontrol noktalarını ve köşelerine uygun olarak eğri düzlemi boşlukta canlandırır. Bunun anlamı düzgün yüzeyli bir nesne oluştururken göreceli olarak daha az köşe ile kontrol edebilirsiniz.

Subsurf (Alt yüz) modifier (düzenleyici) eklemek[değiştir]

Subsurf(alt yüzey) modifier(düzenleyici)

İlk, küp seçin. Şimdi panelden Editing (düzenleyi) seçin. Panel listesinden Blenderediting.png ikonuna tıklayın. Dosya:Edit blen222.png veya F9a basın. (Eğer düğme görünüm panelinde (button view panel) bir grup pencere görmüyorsanız, Link and Materials (bağlantı ve malzemeler), Mesh (yığın), Multires, Modifiers (düzenleyiciler), Shapes (şekiller) gibi, büyük ihtimalle küpün kendisi seçili değildir. Bütün hepsi şartlara duyarlıdır. Bu nedenler Editing (düzenleme) paneli seçtiğiniz şeye göre ögeler gösterecektir.)

Sonra Modifiers (Düzenleyiciler) panelinden Add Modifier (Düzenleyici ekle) düğmesini bulun. (Fare tekerini çevirerek bulun.) Bu düğmeye basmak mümkün olan düzenleyicileri listeleyecektir, burdan Subsurf (alt yüzey) seçeneğini seçmelisiniz. Eski Blender sürümlerinde Subsurf (Alt yüzey) düğmesi Mesh (yığın) panelinde yer almaktadır.

Subsurf (alt yüzey) panelinin Modifiers (düzenleyiciler) panelinin içinde oluştuğunu göreceksiniz (resme bakın) ve görünüm penceresindeki küp düzenleyenin ön tanımlı ayarlarında olduğu gibi kuşatılmış görünecektir.

Subdivision (Alt bölüm) seviyesine ince ayar yapmak (Tweaking)[değiştir]

Subsurf (Alt yüzey) paneli seçeneklerinde iki önemli seçenek bulacaksınız. Levels (Seviyeler) ve Render Levels (3B çıktı seviyeleri). Ne kadar yüksek Levels (seviyeler) ayarlarsanız, daha az pürüzlü algoritma uygulanacaktır ve sizin mesh'iniz daha pürüzsüz görünecektir. Levels (seviyeler) sadece küpün 3B görüntüsünü etkiler. Render Levels (3B çıktı seviyesini) belirleyerek 3B çıktı hazırlanırken uygulanacak seviyeyi görmelisiniz.

Levelsi (seviyeyi) 1'den 2'ye artırmanın küpü nasıl bozduğuna bakın.

Seviyeler (Levels) 1'e ayarlanmış
Seviyeler (Levels) 2'ye ayarlanmış



Ama ben kutu istiyorum![değiştir]

Çoğu kez, bir çeşit subsurf (alt yüzey) açık iken 3B çıktı almak isteyeceksiniz. Gerçek yaşamdaki çoğu şeyin süper keskin hatları olmadığı gerçeği ile yüzleşmelisiniz. Gerçek dünyadaki çoğu durumda nesnelerin daha yumuşak hatları vardır. (Bıçak kenarı, makinadan geçirilmiş dükkanlarda blok malzemeler hariç!) Bu insanların 3B'ye başlarken gözden kaçırdıkları bir gerçektir: 3B bazen imkansız derecede keskin, temiz ve iyi belirlenmiş hatlara sahip olduğundan çok mükemmel görünebilir.

Bu efekt Blender'a şunu söyleyerek düzeltilebilir. Biz küpün orijinalinden daha fazlasını istiyoruz. Biz bunu Edge Creasing (kenar kırıştırma) adı verilen bir araç ile yapacağız. Blender modelindeki her kenarın bir crease (kırıştırma) değeri vardır, Subsurf (alt yüzey) düzenleyicisine kenarların ne kadar keskin olacağını söylemek için kullanılır. Ön tanımlı olarak, bütün kenarların crease (kırışıklık) değeri 0'dır, bu bizim küpümüzün bütün keskin kenarlarını kaybetme nedenidir.

Subdivision (Alt bölüm) yüzeyi kafesini göster[değiştir]

Düzenleme modunda Subsurfed (Alt yüzeyli) küp

Şimdi, şunun hakkında daha önce ne dediğimizi hatırlayın Subsurf (alt yüzey) düzenleyicinin küpün orijinal şeklini hatırlıyor mu? TAB'a basarak düzenleme moduna geçin ve orijinal küpün tel çerçeve ile kuşatılmış düzgün bir küp olduğunu göreceksiniz.

Creasing (kırıştırma) ile değiştirmeden önce, Subsurf (alt yüzey) Levels (seviyesini) 4'e çıkarın böylece efekti daha net göreceksiniz.

Crease(kırıştırmak) için kenar seçmek[değiştir]

3B görünümde, Face (yüz) moduna geçin. CTRL+TAB 'a basın (Faces (yüzleri) seçin) ya da bu ikona basın: Blender Face (yüz) düğmesi.

RMB ile tel küpümüzün kenarlarından birini seçin. (Bu yüzün merkezindeki noktanın yanına tıklanarak yapılabilir.) Yüzlerin rengi griye döndüğünde seçildiğini anlayacaksınız ve seçtiğiniz aydınlatılacak.

Şunu not edin, her ne kadar Face (yüz) modunda olsak da, gerçekten creasing (kırıştırma) yaptığımız edges (kenarlar) bir yüzü hızlıca seçmek dört kenarı seçmek kadar kısa yoldur.

Seçili kenarları Crease (kırıştırma) yapmak[değiştir]

Kenar creases (kırışıklıkları) düzenlemek

Şimdi SHIFT+E'ye (ya da Mesh > Edges > Crease SubSurf) basın ve şimdi fareniz noktalı bir çizgi ile küpe bağlanacak. Mesh üzerindeki efekt etkisini görmek için kibarca sağa sola hareket ettirin.

Değişiklikleri uygulamak için LMB'ye (sol fare tuşu) basın, RMB'ye (sağ fare tuşu) basarak son crease değişikliğinden vazgeçebilirsiniz.


RMB - Sağ fare tuşu (Right Mouse Button) LMB - Sol fare tuşu (Left Mouse Button)

Sonunda gerçek bir küp yapmak[değiştir]

Bevel efekti için bütün kenarlar kırıştırıldı

Yukarıda kenar (edge) crease'den (kırıştırma) vazgeçin ya da başa dönüp yeniden basit subsurf'lü (alt yüzlü) küp çizin. Sonra A tuşuna iki kere basıp tüm yüzleri seçin. Daha önce yapıldığı gibi SHIFT+E basarak crease (kırıştırma) yapın. Sağdaki şekle benzeyene kadar yapın.

TAB tuşuna basıp düzenleme modundan çıkabilirsiniz. Düz küpünüze bakın.


Yeni başlayan kullanıcılar için not: Subsurf (alt yüz) seçeneği modelinizi daha düzgün yaparken, hesapladığınız temel mesh'inizi eğer. Bu çok miktarda kopya yüzey oluşumuna neden olabilir. Subsurf (alt yüz) yapılmadığı zaman çok karmaşık mesh olurlar. Bu seçeneği kullanırken çok dikkatli olun, eğer kaynak mesh'inizi izlemiyorsanız problemlere neden olabilir. Bu tarz yüzey hesaplaması ayrıca skinleri de (kabuk) eğer, sonra nesneye skin (kabuk) yapmayı çok zorlaştırır. Bu rehber boyunca uzun süre çalışmayacağınız bir şey, ama aklınızda bulunması iyi olur.


Önceki ders -- Sonraki ders