Avidemux/SSS

Vikikitap, özgür kütüphane
Gezinti kısmına atla Arama kısmına atla

Hangi versiyonu kullandığımı nasıl öğrenebilirim?[değiştir]

Help > About yolunu izleyin. Burada büyük.küçük versiyonu ve tam revizyon numarasını göreceksiniz (rXXXX). Bu yazının yazıldığı tarihte (28 Temmuz 2009) Avidemux'un son sürümü 2.5 (r5152) idi.

Avidemux'la kaydettiğim dosyanın uzantısını ortam oynatıcım/dosya yöneticim tanımadı[değiştir]

Avidemux, dosya uzantısını otomatik olarak eklemez. "Videom" isminde bir AVI dosyası kaydedeceğiniz zaman, dosyanın adını "Videom.avi" yapın. Eğer yanlışlıkla "Videom" olarak kaydetmişseniz dosya yöneticinizle ismini "videom.avi" olarak değiştirin. Her çıktı formatının kullandığı uzantıların listesini Desteklenen çıktı formatları bölümünde bulabilirsiniz.

Avidemux'la videoma filtre/altyazı ekleyip kaydettiğimde oluşan yeni dosyada bir değişiklik olmadığını görüyorum[değiştir]

Bu genellikle videoyu "Copy" olarak ayarladığınızda oluyor, bu beklenen bir davranış. Copy modunda girdi dosyası, çıktı dosyasına olduğu gibi kopyalanır (copy), herhangi bir fitre veya altyazı eklenmez. Video açılır menüsünde "Copy" seçili olduğu zaman, "Filters" butonu pasif haldedir ve "Video > Filters" yolu izlendiğinde "Video filters cannot be used in copy mode" uyarısı çıkar. Bu sorunu çözmek için "Copy" yerine bir kodlayıcı (encoder) seçmeli, filtreleri eklemeli, sonra tekrar "copy" moduna almalısınız. Bu sayede filtreniz uygulanacak ancak enkode işlemi (türler arasında dönüşüm) olmayacaktır.

Videoya fitre(ler) eklemek için video açılır menüsünden uygun bir encoder (kodlayıcı) (ihtiyaçlarınıza en çok uyan) ardından format ve dosya uzantısını seçin.

UYARI: Avidemux'un eski versiyonları copy modundayken "Video > Filters" yolunu izlediğinizde herhangi bir uyarı yapmıyor ve "Filters" butonunu da pasifleştirmiyor. Ayrıca format "AVI, unpack VOP" (bu format videoyu paketten çıkarıp çıkarmamak istediğinizi soran bir soruya "yes" karşılığını verdiğinizde işlemi otomatik yapıyor) olarak ayarlandığında, video copy modunda kaydediliyor, yani fitreler uygulanmıyor.

Bir DVD veya videoyu Avidemux'la kodladım ancak görüntü bulanık. En güzel görüntü için hangi ayarları yapmalıyım?[değiştir]

Öncelikle, geçerli oturum için "Video > Post processing ..." menüsünü izleyerek post-processing'in kapalı olduğuna emin olun. Ayrıca elbetteki bu işlemi "Tools > Preferences" menüsünü izleyip Video sekmesine gelerek de yapabilirsiniz. Sonraki adım, eğer yeniden boyutlandırma fitresi eklemişseniz bu fitreyi Bilinear veya Bicubic yerine Lanczos3 metodunu kullanarak eklemelisiniz. Lanczos3 en doğru çalışan yeniden boyutlandırıcıdır. Ancak doğal olarak yeniden boyutlandırma detayları öldürür, bunun bir çözümü yok. Ancak bazen ne yapmak istediğinize bağlı olarak yeniden boyutlandırma daha keskin görüntü sağlayabilir. Son olarak kodlayıcı ayarlarında ince ayarlar yapın. Ancak burada her kodlayıcı için en iyi kaliteyi nasıl elde edeceğinizi anlatmayacağız. Kodlayıcıya bağlı ayarlar hakkında geniş bilgiyi Avidemux forumundan veya web'den bulabilirsiniz.

Avidemux'la bir video kodladım ancak bu videoyu çalmaya çalıştığımda sadece siyah bir ekran görüyorum[değiştir]

Medya oynatıcınızın ilgili formatı desteklediğinden emin olun. Örneğin Windows Media Player kullanıyorsanız ve videoyu MPEG-4'e (ASP veya AVC) kodlamışsanız, sisteminizde bir üçüncü parti MPEG-4 çözücüsü kurulu olmalıdır, çünkü Microsoft Windows ilk kurulduğunda MPEG-4 çözücüsü yoktur. Buradan modern ses ve video formatlarının çoğu için çözücüler indirebilirsiniz.

Avidemux'ta videonun sesini duyamıyorum[değiştir]

Tercihlerden (Preferences->Audio->Audio output) doğru ses çıktısının ayarlı olduğundan emin olun. Microsoft Windows'ta, bu win32, Linux'ta ise ALSA, OSS, ESD veya aRts olabilir. Eğer sadece belirli formatların sesini duyamıyorsanız, bu Avidemux'un o formatı desteklemediği veya o format desteği veren çözücünün Avidemux'la derlenmediği anlamına gelir. Help->Built-in Support yolunu izleyerek Avidemux'un hangi formatları desteklediğini öğrenebilirsiniz.

2-pass kodlamasını kullanıyorum ancak çıktı dosyasının boyutu beklediğimden daha büyük (örn. 1200 MB yerine 1300 MB)[değiştir]

2-pass ayarlarında hedef video için yazdığınız boyut sadece video içindir. Ses parçaları bu belirttiğiniz boyutu artırırlar. Sadece videonun boyutunu hesaplamak için Avidemux'taki hesap makinesini kullanın; buraya hedef dosya boyutunu, formatı ve sesin bit oranını girin, Apply düğmesine basın (seçili çözücüde 2-pass video boyutu saklanacaktır) ve kapatın.

Not: Benzer bir problemle Avidemux'un 2.4.4'ten önceki sürümlerinde Windows'ta hedef klasör adresinde ANSI olmayan karakterler (örn. éàùôèí vb.) mevcut olduğunda ve Xvid kodekini kullanıyorsanız yüzleşirsiniz. Böyle bir durumda, stats dosyası oluşturulamaz ve Xvid "fixed quantizer mod"a (quantizer 2 ile) girer. Eğer Avidemux'u güncelleyemeyecek durumdaysanız, bu sorunu aşmak için dosyayı adresi sadece ANSI karakterleri içeren bir klasöre kaydedin.

2-pass kodlamasını kullanıyorum ancak çıktı dosyasının boyutu beklediğimden daha küçük (örn. 1400 MB yerine 800 MB)[değiştir]

Daha küçük dosya boyutu dosyanın zaten kalitesinin düşük olduğu anlamına gelir, Avidemux en büyük kaliteyi elde edecek şekilde kodlamıştır. Videonun ayarlarıyla oynamadan (örneğin çözünürlüğü artırmadan veya daha az sıkıştıran bir kodlayıcı ayarı seçmeden) dosyanın boyutunu artıramazsınız. Bu aslında son derece zararsızdır, dosyanın boyutunu normalinden fazla artırmak istemek mantıksızlıktır. Bir dosyanın en büyük kalitede doğru şekilde kodlanıp kodlanmadığından videoyu Avidemux'la açıp frame type bilgisine bakarak emin olabilirsiniz: Dosya:Frame type.png. Eğer parantez içindeki sayı her frame için 2'yse (veya B-frame'ler için 4'se) bu, dosyanın gerçekten de en düşük quantizer (2) yani en yüksek kalite ile kodlandığı anlamına gelir.

Otomatik AVI dosyası parçalanmasını nasıl engellerim? (4 GB'tan büyük AVI dosyası oluşturma)[değiştir]

Varsayılan olarak, Avidemux 4 GB dosya limiti olan standard AVI dosyaları üretir. OpenDML dosyalarının böyle bir limiti yoktur. Avidemux'ta OpenDML çıktısını etkinleştirmek için tercihlerden "Create OpenDML files"ı işaretlersiniz.

Linux'ta Avidemux'u derledim ancak xxx özelliği veya xxx kodlayıcı/çözücü desteği yok[değiştir]

Kütüphaneler için geliştirme paketlerinin kurulu olduğuna emin olun. Örneğin FAAC desteği için ayrıca (lib)faac-dev veya (lib)faac-devel paketini kurmalı ardından Avidemux'u yeniden derlemelisiniz.

Avidemux DV veya miniDV dosyamı açmıyor[değiştir]

Avidemux, şu an itibarıyla yalnızca type-2 DV dosyalarını açabiliyor. type 1 ve type 2 olmak üzere İki tip DV dosyası var (aralarındaki farkları öğrenmek için: buraya bakın). Ancak, bazı kameralar type-1 DV videosu üretiyor. type 1'i type-2 DV'ye dönüştürmek için, Canopus'un bu aracını veya Ulead'ınkini kullanabilirsiniz.

log dosyasını nerede bulabilirim?[değiştir]

log dosyası (admlog.txt), Avidemux göçtüğünde oluşturulan proje göçme dosyası (crash.js) ile birlikte %APPDATA%/avidemux klasöründe bulunur. Windows Explorer adres çubuğuna %APPDATA%/avidemux/admlog.txt adresini direkt olarak girmeniz durumunda log dosyası açılacaktır (genellikle notepad ile).

İş dosyalarını nerede bulabilirim?[değiştir]

İş dosyalarınızı %APPDATA%/avidemux/jobs klasöründe, .js dosyaları olarak bulabilirsiniz. Herhangi bir düz metin editörüyle değiştirilebilirler.