Avidemux/Kesme

Vikikitap, özgür kütüphane
Gezinti kısmına atla Arama kısmına atla

Temel kesme[değiştir]

Ses/video senkronizasyonu[değiştir]

Sesi değişken bit oranına sahip olan bir video düzenliyorsanız, herhangi bir şey yapmadan önce Audio->Build VBR Time Map menü yolunu izleyin. Aksi halde sesin video ile olan senkronizasyonu bozulacaktır.

İşaretçiler[değiştir]

Video düzenlemeleri yalnızca işaretçiler ile seçilmiş aralığa uygulanır. A ve B işaretçileri, seçilecek bölümün sırayla başlangıcını ve sonunu belirtmek için kullanılır. A ve B noktalarını A ve B düğmelerini kullanarak ayarlarsınız.

A ve B noktalarına Go->Jump to Marker A veya Go->Jump to Marker B menüleriyle gidebilirsiniz.

İşaretçilerin konumları ekranın altında Selection bölümünde de gösterilmektedir:

Selection-gtk.png

A işaretçisi B'den sonra gelemez. Eğer B işaretçisini A'dan sonraya getirmeye çalışırsanız Avidemux B'nin olması gereken yerden bir frame sonrasına A'yı; A'nın olması gereken yere de B'yi yerleştirecektir. Yani örneğin A; 0. frame'de, B de 10. frame'deyken A'yı 20. frame'e taşırsanız Avidemux A'yı 11. frame'e, B'yi de 20. frame'e koyacaktır.

Kaydetme[değiştir]

Akımın istediğiniz bir kısmını File->Save->Save Video menüsünü izleyerek kaydedebilirsiniz. A'dan B'ye kadar olan tüm frame'ler kaydedilecektir (A'nın olduğu frame dahil, ancak B'nin olduğu frame hariç). Matematik diliyle konuşacak olursak [A,B) aralığı kaydedilecektir.

Silme[değiştir]

Edit->Delete menüsü akımdan [A,B) aralığındaki frame'leri silecektir. Bu özellik, yakalanmış bir TV dizisinden reklamları silmek için kullanılabilir. Videoya eklenmiş harici bir ses kaynağı yoksa Avidemux sesin videoyla senkronizasyonunu koruyacaktır.

Harici ses kaynağı[değiştir]

Videonun harici bir ses kaynağı varsa kesme ve silme işlemlerinde Avidemux harici ses kaynağında kesme/silme yapmayacak, dolayısıyla sesle videonun senkronizasyonu bozulacaktır.

Harici ses kaynağı eklenmiş videolarda kesme/silme yaparken senkronizasyonu korumak için iki seçeneğiniz var:

  1. Ses dosyasını kendiniz düzenleyebilirsiniz. Yani bir ses düzenleme programında ses dosyasında kesme işlemi yapabilirsiniz.
  2. Başka ve daha kullanışlı bir yöntemse videoyu Avidemux'la iki kere düzenlemektir.
    • İlk olarak Avidemux'la sesi videoya ekleyip videoyu kaydedin.
    • Şimdi harici ses videoya gömülmüş ve "harici ses kaynağı" artık "dahili ses kaynağı" olmuştur. Kaydettiğiniz videoyu Avidemux'la açın. Artık videoda yaptığınız kesme/silme işlemlerinde senkronizasyon bozulmayacaktır.

Intra frame'ler ve SmartCopy[değiştir]

Bu bölüm yalnızca video Copy modundaysa (kodlayıcı Copy'ye ayarlanmışsa) geçerlidir. İşleme modunda (kodlayıcı için bir kodlayıcı seçildiğinde) Avidemux internalleri her şeyin yolunda olduğu sonucuna varacaktır.

Uyarı: Format "AVI, unpack VOP" olarak ayarlanmışsa Avidemux kodlama için bir video kodlayıcısı seçilmiş olsa bile copy modunu bütün frame'lere uygulayacaktır ("bozuk" olanlar da dahil). SmartCopy modu bu durumda çalışmayacaktır, çünkü SmartCopy bozuk frame'lerin yeniden kodlanmasını gerektirir.

Genelde bir videodaki bir frame, kendinden hemen önceki frame'den pek farklı değildir. Bir adamın ağzı biraz oynar, arkaplan biraz kayar, vb. Birçok video kodeki bu özelliği kullanarak videoların boyutlarını düşürür. Bu kodekler birkaç saniyede bir tam bir frame alırlar, öteki frameleri referans frame'indeki farklarla belirtirler. Bu sayede her frame'in tam olarak dosyada depolanmasına gerek kalmaz. Tam frame'ler Intra frame, I-frame veya keyframe olarak adlandırılır.

İşaretçiler key frame'lere koyulmak zorunda değildir. Örnek bir akım şöyle gözükebilir:

abAdeIghBjklInop

Buradaki küçük harfler ara frame'leri, A ve B işaretli frame'leri ve I de intra frame'leri belirtmektedir. Burada kesme işlemi uyguladığınızda (yani [A,B) aralığındaki frame'leri aldığınızda):

abjklInop

gibi bir şey ortaya çıkacaktır. Burada jkl frame'leri artık olmayan bir frame'den farkları belirtmektedir. Bu frame'lere bozuk frame denir. Bununla baş etmenin iki yolu vardır:

  • B işaretçisinin bir I-frame'de olduğundan emin olun.
  • Eğer dosyanız MSMPEG-4 (DivX 3) veya MPEG-4 videosu kullanıyorsa, smart copy modunu kullanabilirsiniz. Smart copy frame'lerin çoğunu değiştirmez, ancak sabit bir quantizer ile, referansını kaybeden frame'leri yeniden kodlar. Yani örneğimizde ab ve nop değişmeden kalacak, ancak jkl frame'leri farklı bir referans frame'i kullanacak şekilde yeniden kodlanacaktır. Smart copy, quantizer'in kullanacağı değeri soracaktır - 4 veya 5 genelde iyidir.

Kopyala/yapıştır[değiştir]

Frame'ler CTRL+C ve CTRL+V tuş bileşimleriyle kopyalanıp yapıştırılabilir. Kopyalama yaparken ilk frame'in bir I-frame olduğundan emin olun; yapıştırmayı ise bir I-frame'den hemen önce bir yere yapın. Smart copy, bu durumda da çalışmaktadır (ancak ilgili akımın B-frame içermemesi gerekir).

Frame kesme/silme örneği[değiştir]

VBR zaman haritasını inşa etme[değiştir]

1. Değişken bit oranına sahip ses içeren bir dosya düzenliyorsanız herhangi bir şey yapmadan önce Audio->Build VBR Time Map menüsünü izleyin. Aksi durumda sesinizin videoyla senkronizasyonu bozulacaktır.

İşaretçiler[değiştir]

2. Düzenlemek istediğiniz aralığın başına A düğmesiyle A işareti koyun.

3. Düzenlemek istediğiniz aralığın sonuna B düğmesiyle B işareti koyun.

Başlangıç ve bitiş noktalarından emin olmak için ekranın alt kısmındaki Selection kısmına bakın:

Selection-gtk.png

Kesme/silme[değiştir]

4. Edit->Delete menüsü, akımdan [A,B) aralığındaki frame'leri silecektir.

Videoyu kaydetme[değiştir]

5. File->Save->Save Video menüsü aracılıyla videoyu bazı istediğiniz kısımları silinmiş halde kaydedersiniz. Bu değişikliği (silme işlemini) yapabilmek için bazen Video Copy ve Audio Copy modları yeterli olabilirken, bazen de illaki kodlama yapmanız gerekebilmektedir.

Gelişmiş kesme[değiştir]

Otomatik bölme[değiştir]

File->AVI Muxer Options menüsünü kullanarak megabyte olarak bir dosya boyutu belirtebilirsiniz. Dosyada ilgili dosya boyutuna ve bir intra frame'e her varıldığı anda Avidemux yeni bir dosya oluşturacaktır. Ortaya dosya.avi.1, dosya.avi.2 gibi dosyalar çıkacaktır.

Oluşturulan her dosya bir I-frame'le başlaması gerektiğinden oluşturulan her dosyanın belirttiğiniz dosya boyutunda olması garantisi verilemez, aşağı yukarı 5 MB oynar.